Labflow.ca (CANADA/ALL USERS) Service Disruption Incident

Incident Report for Catalyst Education

Postmortem

We are continuing to monitor the status of Labflow.ca and will be adding additional system health checks.

Posted Jun 25, 2024 - 13:38 CDT

Resolved

Labflow Service Disruption Incident

Severity: Complete Disruption

Impacted: All Labflow.ca users. (CANADA/ALL USERS)

Status: Resolved

Incident Impact:
At 12:30pm (CST) on 6/25/24, All Labflow.ca users became unable to access the Labflow.ca site.

Time Frame:

Starting at: First Observed At 12:30pm (CST) on 6/25/24
Ending at: 1:11PM (CST)
Duration: 41 MINUTES

Incident Overview:

All users logging into Labflow.ca were unable to access the site.

Root Cause: The cause of this issue is due to an invalid SSL certificate for the .ca domain. In the most recent software version of Labflow that was deployed on 6/24/24, the retained valid SSL domain certificate for Labflow.ca was not included in its proper iteration.

Mitigations:

The Labflow support team deployed a fix in the latest version of the Labflow platform software, which has resolved all issues related to the incident.
Posted Jun 25, 2024 - 12:30 CDT