Labflow Service Degradation

Incident Report for Catalyst Education

Resolved

This incident has been resolved. At this time please feel free to resume using Labflow. The Catalyst Education team will append a full incident report in the coming days as Google provides more information on the root cause of this incident.

If you are still experiencing errors, please reach out to support@labflow.com with any concerns. We sincerely apologize for any inconvenience that this may have caused.
Posted Jun 12, 2025 - 16:26 CDT

Monitoring

We are observing a recovery in the Google Cloud services that Labflow relies on. At this time you may resume normal activity in Labflow. We will send a final update after Google confirms that the outage has been fully resolved.
Posted Jun 12, 2025 - 15:50 CDT

Update

Google is reporting that services are continuing to slowly come online. The Catalyst Education team is still observing intermittent connectivity issues with Google Cloud services. We recommend continuing to wait to submit your work until the outage has been resolved.

We will give another update as soon as we have more information from Google, see improvements in Labflow performance, or in 30 minutes.
Posted Jun 12, 2025 - 15:39 CDT

Identified

Google Cloud is still experiencing widespread service outages. Google engineers are beginning to apply fixes and workarounds but we are still awaiting confirmation that Google's services that Labflow relies on are fully operational.

We will give another update as soon as we have more information from Google, see improvements in Labflow performance, or in 30 minutes.
Posted Jun 12, 2025 - 14:59 CDT

Investigating

Google Cloud Platform is experiencing degraded networking performance and service outages. Labflow is hosted on Google Cloud Platform and is also experiencing degraded performance. This is also affecting other services hosted on Google's cloud including Cloudflare, Spotify, Snapchat, and many others.

We are diligently monitoring the situation and will report back with any updates from Google.

At this time you may experience "red banner" errors. To avoid any data integrity issues, we recommend waiting to submit your work until the outage has been resolved.
Posted Jun 12, 2025 - 13:54 CDT
This incident affected: Labflow App.